summaryrefslogtreecommitdiffstatshomepage
path: root/3rdparty/libflac/src/metaflac/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/libflac/src/metaflac/Makefile.am')
-rw-r--r--3rdparty/libflac/src/metaflac/Makefile.am39
1 files changed, 25 insertions, 14 deletions
diff --git a/3rdparty/libflac/src/metaflac/Makefile.am b/3rdparty/libflac/src/metaflac/Makefile.am
index 92aa50bf467..8c212ff40e2 100644
--- a/3rdparty/libflac/src/metaflac/Makefile.am
+++ b/3rdparty/libflac/src/metaflac/Makefile.am
@@ -1,5 +1,6 @@
# metaflac - Command-line FLAC metadata editor
-# Copyright (C) 2000,2001,2002,2003,2004,2005,2006,2007 Josh Coalson
+# Copyright (C) 2000-2009 Josh Coalson
+# Copyright (C) 2011-2023 Xiph.Org Foundation
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
@@ -11,18 +12,25 @@
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+if OS_IS_WINDOWS
+win_utf8_lib = $(top_builddir)/src/share/win_utf8_io/libwin_utf8_io.la
+if HAVE_WINDRES
+metaflac_DEPENDENCIES = version.o
+windows_resource_link = -Wl,version.o
+endif
+endif
bin_PROGRAMS = metaflac
AM_CFLAGS = @OGG_CFLAGS@
-
+AM_CPPFLAGS = -I$(top_builddir) -I$(srcdir)/include -I$(top_srcdir)/include
EXTRA_DIST = \
- Makefile.lite \
- metaflac.dsp \
- metaflac.vcproj
+ CMakeLists.txt \
+ version.rc
metaflac_SOURCES = \
main.c \
@@ -40,15 +48,18 @@ metaflac_SOURCES = \
options.h \
usage.h \
utils.h
-metaflac_LDFLAGS =
+metaflac_LDFLAGS = $(AM_LDFLAGS) $(windows_resource_link)
metaflac_LDADD = \
$(top_builddir)/src/share/grabbag/libgrabbag.la \
$(top_builddir)/src/share/replaygain_analysis/libreplaygain_analysis.la \
- $(top_builddir)/src/share/getopt/libgetopt.a \
+ $(top_builddir)/src/share/getopt/libgetopt.la \
$(top_builddir)/src/share/utf8/libutf8.la \
$(top_builddir)/src/libFLAC/libFLAC.la \
- @OGG_LIBS@ \
- @LIBICONV@ \
- @MINGW_WINSOCK_LIBS@ \
- -lm
+ $(win_utf8_lib) \
+ @LTLIBICONV@
+
+CLEANFILES = metaflac.exe
+
+.rc.o:
+ $(RC) $(AM_CPPFLAGS) $< $@