summaryrefslogtreecommitdiffstatshomepage
path: root/3rdparty/libflac/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/libflac/Makefile.am')
-rw-r--r--3rdparty/libflac/Makefile.am35
1 files changed, 22 insertions, 13 deletions
diff --git a/3rdparty/libflac/Makefile.am b/3rdparty/libflac/Makefile.am
index 5627bb54133..3bb523e880d 100644
--- a/3rdparty/libflac/Makefile.am
+++ b/3rdparty/libflac/Makefile.am
@@ -1,8 +1,9 @@
# FLAC - Free Lossless Audio Codec
-# Copyright (C) 2001,2002,2003,2004,2005,2006,2007 Josh Coalson
+# Copyright (C) 2001-2009 Josh Coalson
+# Copyright (C) 2011-2023 Xiph.Org Foundation
#
# This file is part the FLAC project. FLAC is comprised of several
-# components distributed under difference licenses. The codec libraries
+# components distributed under different licenses. The codec libraries
# are distributed under Xiph.Org's BSD-like license (see the file
# COPYING.Xiph in this distribution). All other programs, libraries, and
# plugins are distributed under the GPL (see COPYING.GPL). The documentation
@@ -28,25 +29,33 @@
# distclean: remove everything except what goes in the distribution
#
-AUTOMAKE_OPTIONS = foreign 1.7
+ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = doc include m4 man src examples test build obj
+SUBDIRS = doc include m4 man src test microbench oss-fuzz
-DISTCLEANFILES = libtool-disable-static
+if EXAMPLES
+SUBDIRS += examples
+endif
EXTRA_DIST = \
+ CMakeLists.txt \
+ config.cmake.h.in \
+ flac-config.cmake.in \
+ cmake/CheckA64NEON.c.in \
+ cmake/CheckA64NEON.cmake \
+ cmake/CheckCPUArch.c.in \
+ cmake/CheckCPUArch.cmake \
+ cmake/FindOgg.cmake \
+ cmake/UseSystemExtensions.cmake \
+ CHANGELOG.md \
COPYING.FDL \
COPYING.GPL \
COPYING.LGPL \
COPYING.Xiph \
- FLAC.dsw \
- FLAC.sln \
- Makefile.lite \
- all.dsp \
- all_dynamic.dsp \
- all_static.dsp \
+ README.md \
autogen.sh \
config.rpath \
depcomp \
- ltmain.sh \
- strip_non_asm_libtool_args.sh
+ ltmain.sh
+
+CLEANFILES = *~