summaryrefslogtreecommitdiffstatshomepage
path: root/3rdparty/asio/src/examples/cpp17/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/asio/src/examples/cpp17/Makefile.am')
-rw-r--r--3rdparty/asio/src/examples/cpp17/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/3rdparty/asio/src/examples/cpp17/Makefile.am b/3rdparty/asio/src/examples/cpp17/Makefile.am
new file mode 100644
index 00000000000..c3a571c02f4
--- /dev/null
+++ b/3rdparty/asio/src/examples/cpp17/Makefile.am
@@ -0,0 +1,37 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
+if SEPARATE_COMPILATION
+noinst_LIBRARIES = libasio.a
+libasio_a_SOURCES = ../../asio.cpp
+if HAVE_OPENSSL
+libasio_a_SOURCES += ../../asio_ssl.cpp
+endif
+LDADD = libasio.a
+endif
+
+if HAVE_COROUTINES
+noinst_PROGRAMS = \
+ coroutines_ts/chat_server \
+ coroutines_ts/echo_server \
+ coroutines_ts/echo_server_with_default \
+ coroutines_ts/echo_server_with_as_single_default \
+ coroutines_ts/echo_server_with_as_tuple_default \
+ coroutines_ts/refactored_echo_server
+endif
+
+AM_CXXFLAGS = -I$(srcdir)/../../../include
+
+if HAVE_COROUTINES
+coroutines_ts_chat_server_SOURCES = coroutines_ts/chat_server.cpp
+coroutines_ts_echo_server_SOURCES = coroutines_ts/echo_server.cpp
+coroutines_ts_echo_server_with_default_SOURCES = coroutines_ts/echo_server_with_default.cpp
+coroutines_ts_echo_server_with_as_single_default_SOURCES = coroutines_ts/echo_server_with_as_single_default.cpp
+coroutines_ts_echo_server_with_as_tuple_default_SOURCES = coroutines_ts/echo_server_with_as_tuple_default.cpp
+coroutines_ts_refactored_echo_server_SOURCES = coroutines_ts/refactored_echo_server.cpp
+endif
+
+EXTRA_DIST = \
+ coroutines_ts/range_based_for.cpp
+
+MAINTAINERCLEANFILES = \
+ $(srcdir)/Makefile.in