summaryrefslogtreecommitdiffstatshomepage
path: root/3rdparty/asio/src/examples/cpp11/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/asio/src/examples/cpp11/Makefile.am')
-rw-r--r--3rdparty/asio/src/examples/cpp11/Makefile.am73
1 files changed, 72 insertions, 1 deletions
diff --git a/3rdparty/asio/src/examples/cpp11/Makefile.am b/3rdparty/asio/src/examples/cpp11/Makefile.am
index 182c711229f..bc2e1034021 100644
--- a/3rdparty/asio/src/examples/cpp11/Makefile.am
+++ b/3rdparty/asio/src/examples/cpp11/Makefile.am
@@ -27,8 +27,44 @@ noinst_PROGRAMS = \
executors/pipeline \
executors/priority_scheduler \
futures/daytime_client \
+ handler_tracking/async_tcp_echo_server \
http/server/http_server \
- iostreams/http_client
+ invocation/prioritised_handlers \
+ iostreams/http_client \
+ multicast/receiver \
+ multicast/sender \
+ nonblocking/third_party_lib \
+ operations/composed_1 \
+ operations/composed_2 \
+ operations/composed_3 \
+ operations/composed_4 \
+ operations/composed_5 \
+ operations/composed_6 \
+ operations/composed_7 \
+ operations/composed_8 \
+ socks4/sync_client \
+ timeouts/async_tcp_client \
+ timeouts/blocking_tcp_client \
+ timeouts/blocking_token_tcp_client \
+ timeouts/blocking_udp_client \
+ timeouts/server \
+ timers/time_t_timer
+
+if !WINDOWS_TARGET
+noinst_PROGRAMS += \
+ fork/daemon \
+ fork/process_per_connection \
+ local/connect_pair \
+ local/iostream_client \
+ local/stream_server \
+ local/stream_client
+endif
+
+if HAVE_OPENSSL
+noinst_PROGRAMS += \
+ ssl/client \
+ ssl/server
+endif
if HAVE_BOOST_COROUTINE
noinst_PROGRAMS += \
@@ -37,6 +73,7 @@ noinst_PROGRAMS += \
endif
noinst_HEADERS = \
+ socks4/socks4.hpp \
chat/chat_message.hpp
AM_CXXFLAGS = -I$(srcdir)/../../../include
@@ -58,6 +95,7 @@ executors_fork_join_SOURCES = executors/fork_join.cpp
executors_pipeline_SOURCES = executors/pipeline.cpp
executors_priority_scheduler_SOURCES = executors/priority_scheduler.cpp
futures_daytime_client_SOURCES = futures/daytime_client.cpp
+handler_tracking_async_tcp_echo_server_SOURCES = handler_tracking/async_tcp_echo_server.cpp
http_server_http_server_SOURCES = \
http/server/connection.cpp \
http/server/connection_manager.cpp \
@@ -67,7 +105,40 @@ http_server_http_server_SOURCES = \
http/server/request_handler.cpp \
http/server/request_parser.cpp \
http/server/server.cpp
+invocation_prioritised_handlers_SOURCES = invocation/prioritised_handlers.cpp
iostreams_http_client_SOURCES = iostreams/http_client.cpp
+multicast_receiver_SOURCES = multicast/receiver.cpp
+multicast_sender_SOURCES = multicast/sender.cpp
+nonblocking_third_party_lib_SOURCES = nonblocking/third_party_lib.cpp
+operations_composed_1_SOURCES = operations/composed_1.cpp
+operations_composed_2_SOURCES = operations/composed_2.cpp
+operations_composed_3_SOURCES = operations/composed_3.cpp
+operations_composed_4_SOURCES = operations/composed_4.cpp
+operations_composed_5_SOURCES = operations/composed_5.cpp
+operations_composed_6_SOURCES = operations/composed_6.cpp
+operations_composed_7_SOURCES = operations/composed_7.cpp
+operations_composed_8_SOURCES = operations/composed_8.cpp
+socks4_sync_client_SOURCES = socks4/sync_client.cpp
+timeouts_async_tcp_client_SOURCES = timeouts/async_tcp_client.cpp
+timeouts_blocking_tcp_client_SOURCES = timeouts/blocking_tcp_client.cpp
+timeouts_blocking_token_tcp_client_SOURCES = timeouts/blocking_token_tcp_client.cpp
+timeouts_blocking_udp_client_SOURCES = timeouts/blocking_udp_client.cpp
+timeouts_server_SOURCES = timeouts/server.cpp
+timers_time_t_timer_SOURCES = timers/time_t_timer.cpp
+
+if !WINDOWS_TARGET
+fork_daemon_SOURCES = fork/daemon.cpp
+fork_process_per_connection_SOURCES = fork/process_per_connection.cpp
+local_connect_pair_SOURCES = local/connect_pair.cpp
+local_iostream_client_SOURCES = local/iostream_client.cpp
+local_stream_server_SOURCES = local/stream_server.cpp
+local_stream_client_SOURCES = local/stream_client.cpp
+endif
+
+if HAVE_OPENSSL
+ssl_client_SOURCES = ssl/client.cpp
+ssl_server_SOURCES = ssl/server.cpp
+endif
if HAVE_BOOST_COROUTINE
spawn_echo_server_SOURCES = spawn/echo_server.cpp