summaryrefslogtreecommitdiffstatshomepage
path: root/3rdparty/asio/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/asio/src/Makefile.am')
-rw-r--r--3rdparty/asio/src/Makefile.am24
1 files changed, 19 insertions, 5 deletions
diff --git a/3rdparty/asio/src/Makefile.am b/3rdparty/asio/src/Makefile.am
index c308ea0a769..e9b20e607e9 100644
--- a/3rdparty/asio/src/Makefile.am
+++ b/3rdparty/asio/src/Makefile.am
@@ -1,14 +1,28 @@
-if STANDALONE
-SUBDIRS = examples/cpp11 tests
-else
-SUBDIRS = examples/cpp03 tests
+if !STANDALONE
+EXAMPLES_CPP03 = examples/cpp03
endif
-DIST_SUBDIRS = examples/cpp03 examples/cpp11 examples/cpp14 tests
+if HAVE_CXX11
+EXAMPLES_CPP11 = examples/cpp11
+endif
+
+if HAVE_CXX14
+EXAMPLES_CPP14 = examples/cpp14
+endif
+
+if HAVE_CXX17
+EXAMPLES_CPP17 = examples/cpp17
+endif
+
+SUBDIRS = $(EXAMPLES_CPP03) $(EXAMPLES_CPP11) $(EXAMPLES_CPP14) $(EXAMPLES_CPP17) tests
+
+DIST_SUBDIRS = examples/cpp03 examples/cpp11 examples/cpp14 examples/cpp17 tests
EXTRA_DIST = \
Makefile.mgw \
Makefile.msc \
+ tools/handlerlive.pl \
+ tools/handlertree.pl \
tools/handlerviz.pl
MAINTAINERCLEANFILES = \