summaryrefslogtreecommitdiffstatshomepage
path: root/3rdparty/asio/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/asio/src/Makefile.am')
-rw-r--r--3rdparty/asio/src/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/3rdparty/asio/src/Makefile.am b/3rdparty/asio/src/Makefile.am
new file mode 100644
index 00000000000..e9b20e607e9
--- /dev/null
+++ b/3rdparty/asio/src/Makefile.am
@@ -0,0 +1,29 @@
+if !STANDALONE
+EXAMPLES_CPP03 = examples/cpp03
+endif
+
+if HAVE_CXX11
+EXAMPLES_CPP11 = examples/cpp11
+endif
+
+if HAVE_CXX14
+EXAMPLES_CPP14 = examples/cpp14
+endif
+
+if HAVE_CXX17
+EXAMPLES_CPP17 = examples/cpp17
+endif
+
+SUBDIRS = $(EXAMPLES_CPP03) $(EXAMPLES_CPP11) $(EXAMPLES_CPP14) $(EXAMPLES_CPP17) tests
+
+DIST_SUBDIRS = examples/cpp03 examples/cpp11 examples/cpp14 examples/cpp17 tests
+
+EXTRA_DIST = \
+ Makefile.mgw \
+ Makefile.msc \
+ tools/handlerlive.pl \
+ tools/handlertree.pl \
+ tools/handlerviz.pl
+
+MAINTAINERCLEANFILES = \
+ $(srcdir)/Makefile.in