summaryrefslogtreecommitdiffstatshomepage
path: root/3rdparty/portmidi/pm_test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/portmidi/pm_test/CMakeLists.txt')
-rw-r--r--3rdparty/portmidi/pm_test/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/3rdparty/portmidi/pm_test/CMakeLists.txt b/3rdparty/portmidi/pm_test/CMakeLists.txt
new file mode 100644
index 00000000000..b89074b0bd5
--- /dev/null
+++ b/3rdparty/portmidi/pm_test/CMakeLists.txt
@@ -0,0 +1,26 @@
+# pm_test
+
+# set the build directory to be in portmidi, not in portmidi/pm_test
+# this is required for Xcode:
+if(APPLE)
+set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_BINARY_DIR})
+endif(APPLE)
+
+if(WIN32)
+include(../pm_win/static.cmake)
+endif(WIN32)
+
+macro(make_a_test name)
+ add_executable(${name} ${name}.c)
+ target_link_libraries(${name} portmidi-static ${PM_NEEDED_LIBS})
+ add_dependencies(${name} portmidi-static)
+endmacro(make_a_test)
+
+make_a_test(test)
+make_a_test(midithread)
+make_a_test(midithru)
+make_a_test(sysex)
+make_a_test(latency)
+make_a_test(mm)
+make_a_test(midiclock)
+make_a_test(qtest)