summaryrefslogtreecommitdiffstatshomepage
path: root/3rdparty/libflac/src/share/getopt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/libflac/src/share/getopt/Makefile.am')
-rw-r--r--3rdparty/libflac/src/share/getopt/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/3rdparty/libflac/src/share/getopt/Makefile.am b/3rdparty/libflac/src/share/getopt/Makefile.am
new file mode 100644
index 00000000000..f40464e638b
--- /dev/null
+++ b/3rdparty/libflac/src/share/getopt/Makefile.am
@@ -0,0 +1,20 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = foreign
+
+INCLUDES = -I$(top_srcdir)/include/share
+
+noinst_LIBRARIES = libgetopt.a
+
+libgetopt_a_SOURCES = getopt.c getopt1.c
+
+EXTRA_DIST = \
+ Makefile.lite \
+ getopt_static.dsp \
+ getopt_static.vcproj
+
+debug:
+ $(MAKE) all CFLAGS="@DEBUG@"
+
+profile:
+ $(MAKE) all CFLAGS="@PROFILE@"