summaryrefslogtreecommitdiffstatshomepage
path: root/3rdparty/bgfx/3rdparty/spirv-tools/source/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/bgfx/3rdparty/spirv-tools/source/fuzz/CMakeLists.txt')
-rw-r--r--3rdparty/bgfx/3rdparty/spirv-tools/source/fuzz/CMakeLists.txt40
1 files changed, 37 insertions, 3 deletions
diff --git a/3rdparty/bgfx/3rdparty/spirv-tools/source/fuzz/CMakeLists.txt b/3rdparty/bgfx/3rdparty/spirv-tools/source/fuzz/CMakeLists.txt
index b21d210d055..627fcba87f8 100644
--- a/3rdparty/bgfx/3rdparty/spirv-tools/source/fuzz/CMakeLists.txt
+++ b/3rdparty/bgfx/3rdparty/spirv-tools/source/fuzz/CMakeLists.txt
@@ -30,6 +30,7 @@ if(SPIRV_BUILD_FUZZER)
set(SPIRV_TOOLS_FUZZ_SOURCES
data_descriptor.h
+ equivalence_relation.h
fact_manager.h
force_render_red.h
fuzzer.h
@@ -37,14 +38,21 @@ if(SPIRV_BUILD_FUZZER)
fuzzer_pass.h
fuzzer_pass_add_dead_breaks.h
fuzzer_pass_add_dead_continues.h
+ fuzzer_pass_add_no_contraction_decorations.h
fuzzer_pass_add_useful_constructs.h
+ fuzzer_pass_adjust_function_controls.h
+ fuzzer_pass_adjust_loop_controls.h
+ fuzzer_pass_adjust_memory_operands_masks.h
+ fuzzer_pass_adjust_selection_controls.h
fuzzer_pass_apply_id_synonyms.h
+ fuzzer_pass_construct_composites.h
fuzzer_pass_copy_objects.h
fuzzer_pass_obfuscate_constants.h
fuzzer_pass_permute_blocks.h
fuzzer_pass_split_blocks.h
fuzzer_util.h
id_use_descriptor.h
+ instruction_descriptor.h
protobufs/spirvfuzz_protobufs.h
pseudo_random_generator.h
random_generator.h
@@ -55,15 +63,22 @@ if(SPIRV_BUILD_FUZZER)
transformation_add_constant_scalar.h
transformation_add_dead_break.h
transformation_add_dead_continue.h
+ transformation_add_no_contraction_decoration.h
transformation_add_type_boolean.h
transformation_add_type_float.h
transformation_add_type_int.h
transformation_add_type_pointer.h
+ transformation_composite_construct.h
+ transformation_composite_extract.h
transformation_copy_object.h
transformation_move_block_down.h
transformation_replace_boolean_constant_with_constant_binary.h
transformation_replace_constant_with_uniform.h
transformation_replace_id_with_synonym.h
+ transformation_set_function_control.h
+ transformation_set_loop_control.h
+ transformation_set_memory_operands_mask.h
+ transformation_set_selection_control.h
transformation_split_block.h
uniform_buffer_element_descriptor.h
${CMAKE_CURRENT_BINARY_DIR}/protobufs/spvtoolsfuzz.pb.h
@@ -76,14 +91,21 @@ if(SPIRV_BUILD_FUZZER)
fuzzer_pass.cpp
fuzzer_pass_add_dead_breaks.cpp
fuzzer_pass_add_dead_continues.cpp
+ fuzzer_pass_add_no_contraction_decorations.cpp
fuzzer_pass_add_useful_constructs.cpp
+ fuzzer_pass_adjust_function_controls.cpp
+ fuzzer_pass_adjust_loop_controls.cpp
+ fuzzer_pass_adjust_memory_operands_masks.cpp
+ fuzzer_pass_adjust_selection_controls.cpp
fuzzer_pass_apply_id_synonyms.cpp
+ fuzzer_pass_construct_composites.cpp
fuzzer_pass_copy_objects.cpp
fuzzer_pass_obfuscate_constants.cpp
fuzzer_pass_permute_blocks.cpp
fuzzer_pass_split_blocks.cpp
fuzzer_util.cpp
id_use_descriptor.cpp
+ instruction_descriptor.cpp
pseudo_random_generator.cpp
random_generator.cpp
replayer.cpp
@@ -93,15 +115,22 @@ if(SPIRV_BUILD_FUZZER)
transformation_add_constant_scalar.cpp
transformation_add_dead_break.cpp
transformation_add_dead_continue.cpp
+ transformation_add_no_contraction_decoration.cpp
transformation_add_type_boolean.cpp
transformation_add_type_float.cpp
transformation_add_type_int.cpp
transformation_add_type_pointer.cpp
+ transformation_composite_construct.cpp
+ transformation_composite_extract.cpp
transformation_copy_object.cpp
transformation_move_block_down.cpp
transformation_replace_boolean_constant_with_constant_binary.cpp
transformation_replace_constant_with_uniform.cpp
transformation_replace_id_with_synonym.cpp
+ transformation_set_function_control.cpp
+ transformation_set_loop_control.cpp
+ transformation_set_memory_operands_mask.cpp
+ transformation_set_selection_control.cpp
transformation_split_block.cpp
uniform_buffer_element_descriptor.cpp
${CMAKE_CURRENT_BINARY_DIR}/protobufs/spvtoolsfuzz.pb.cc
@@ -131,8 +160,6 @@ if(SPIRV_BUILD_FUZZER)
target_include_directories(SPIRV-Tools-fuzz
PUBLIC
$<BUILD_INTERFACE:${spirv-tools_SOURCE_DIR}/include>
- $<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}/include>
- PUBLIC
$<BUILD_INTERFACE:${SPIRV_HEADER_INCLUDE_DIR}>
$<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>
PRIVATE ${spirv-tools_BINARY_DIR}
@@ -152,7 +179,14 @@ if(SPIRV_BUILD_FUZZER)
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
- install(EXPORT SPIRV-Tools-fuzzTargets DESTINATION lib/cmake)
+ export(EXPORT SPIRV-Tools-fuzzTargets FILE SPIRV-Tools-fuzzTarget.cmake)
+
+ spvtools_config_package_dir(SPIRV-Tools-fuzz PACKAGE_DIR)
+ install(EXPORT SPIRV-Tools-fuzzTargets FILE SPIRV-Tools-fuzzTarget.cmake
+ DESTINATION ${PACKAGE_DIR})
+
+ spvtools_generate_config_file(SPIRV-Tools-fuzz)
+ install(FILES ${CMAKE_BINARY_DIR}/SPIRV-Tools-fuzzConfig.cmake DESTINATION ${PACKAGE_DIR})
endif(ENABLE_SPIRV_TOOLS_INSTALL)
endif(SPIRV_BUILD_FUZZER)